Adobe Lightroom Issues: My plug-ins do not appear in Adobe Lightroom Classic CC after installing. How do I fix this?

This information applies to version(s): 2018, 2, 3, 4, 5

After running a Nik Collection installer, the software may occasionally not be installed correctly in Adobe Lightroom Classic CC. This seems to occur when the “Store Presets with Catalog” option in Lightroom's Preferences is checked. This option is in Edit > Preferences > Presets OR Lightroom > Preferences > Presets. Unchecking this box will make all of the plug-ins appear in the Photo > Edit In menu.

If the filters do not appear in Adobe Lightroom Classic CC then a manual installation may be necessary. To install one of the Nik Collection products manually after the installer has been run, please do the following:

  1. Ensure all image editing applications such as Adobe Photoshop and Adobe Lightroom are closed.
  2. Reinstall Nik Collection, but make sure first that you've uninstalled all previous versions, and that the default install location is used (C:\Program Files\DxO\Nik Collection OR Macintosh HD | Applications | Nik Collection).
  3. Open Lightroom again and check whether the Nik Collection product is now installed under Photo > Edit In> [name of application]. If it does not appear, please continue to step 4.
  4. While Lightroom is still open, click Edit> Preferences OR Lightroom > Preferences.
  5. Click on the "External Editing" tab at the top of preferences.
  6. Midway down on the right click on the "Choose" button and locate the Nik Collection application file for your product using the guidelines below.
    • NOTE: The location of the files needed varies between different Nik Collection versions:
      • Nik Collection 5:
        • HDR, Dfine, and Sharpener are typically found at either, C:\Program Files\DxO\Nik Collection\Dfine\Dfine 2.exe, OR Macintosh HD/Applications/Nik Collection/Dfine 2. For other applications, replace Dfine 2 with the appropriate name.
        • Windows only: Nik Silver Efex Pro, Nik Analog Efex Pro, Nik Color Efex Pro, and Viveza are located at either, C:\Program Files\DxO\Nik Collection\bin\Viveza 3.exe. For other applications, replace Viveza 3 with the appropriate name.
      • Nik Collection 4:
        • Nik Color Efex Pro, Nik Analog Efex Pro, HDR, Dfine, and Sharpener are typically located at either, C:\Program Files\DxO\Nik Collection\Analog Efex Pro 2\Analog Efex Pro 2.exe, OR Macintosh HD/Applications/Nik Collection/Analog Efex Pro 2. For other applications, replace Analog Efex Pro 2 with the appropriate name.
        • Windowns only: Nik Silver Efex Pro and Viveza should be located at either, C:\Program Files\DxO\Nik Collection\bin\Viveza 3.exe. For other applications, replace Viveza 3 with the appropriate name.
      • Nik Collection 2018, 2, 3:
        • Typically found at either, C:\Program Files\DxO\Nik Collection\Viveza 2\Viveza 2.exe, OR Macintosh HD/Applications/Nik Collection/Analog Efex Pro 2. For other applications, replace Viveza 2 with the appropriate name.
  7. Once located, select the program or application file as indicated above and click "Choose".
  8. Set the file format to "TIFF", Color Space to sRGB (or the one of your choice), Bit Depth to 16-bit, Resolution to 240, and Compress to None.
  9. Under Preset click, the drop-down selector and choose, "Save Current Settings as New Preset" from the list.
  10. Type in the name of the plug-in such as "Viveza 3" and click Create.

You may add another plug-in by going back and following steps 6 - 10 again, otherwise close preferences by clicking OK. The plug-in(s) you added should now be accessible.

Please note that this does not apply to HDR Efex Pro 2, which is handled differently from the other plug-ins. HDR Efex Pro 2 is accessible in Lightroom under File>Export with Preset.

Was this article helpful?

15 out of 25 found this helpful

You haven't found the answer to your questions?

You can send us a request
Send a request