A message states that installation requires OS X 10.7 or later, and the process fails even though my OS is up to date. Why?

This information applies to version(s): 2018, 2, 3

I'm getting a message, that installation requires OS X 10.7 or later and fails even though I have a current OS.

Your version of Nik Collection was released before any information about subsequent Mac operating systems was available to the developers, so the error message could not take them into account.

Unfortunately Nik Collection 2018 by DxO and Nik Collection 2 or 3 by DxO are not compatible with macOS Big Sur, Monterey, or Ventura. This is due to the structure and security settings of the new volume scheme used by these OS versions.

To see the compatibility tables with operating systems and third-party software directly from this article, please click on this link.

In this case, your options are either to purchase the current version of Nik Collection by DxO or to run the version of Nik Collection by DxO that you already own on any of the OSes which are listed as supported.

Was this article helpful?

1 out of 6 found this helpful

You haven't found the answer to your questions?

You can send us a request
Send a request