How can I install optical modules for newly supported cameras to use with my older version of DxO PhotoLab?

This information applies to all versions

It is not possible to use modules created for a newer version. The modules are specifically created to be compatible with the newest version of DxO PhotoLab, so in order to use DxO PhotoLab with the newly supported cameras, you will need to upgrade to the current version via your customer account. Our system will walk you through the upgrade process and calculate your cost based on what you currently own.

To log in to your Customer Account directly from this article, please click on this link.

Was this article helpful?

4 out of 12 found this helpful

You haven't found the answer to your questions?

You can send us a request
Send a request